Banking Products

Resources

WE'RE ALWAYS OPEN

1-888-643-3888

Call toll-free, 24x7

System Requirements

Online Account Opening and e-Bankoh® Online Banking Minimum Browser Requirements:

In order for you to successfully open an account online or access e-Bankoh Online Banking, the following minimum browser requirements are necessary (updated 06/2015):

Operating System
Internet Explorer
Apple Safari®
Mozilla Firefox
Google ChromeTM
Windows Vista®
9.0
4.0, 5.0
35.0, 36.0

38.0, 39.0

Windows 7
10.0 - 11.0
-
35.0, 36.0

38.0, 39.0

Windows 8
10.0
-
35.0, 36.0

38.0, 39.0

Windows 8.1
11.0
-
35.0, 36.0

38.0, 39.0

Mac OS X 10.9 (Mavericks™)
-
7.0
35.0, 36.0
-

Mac OS X 10.10
(Yosemite™)

-
7.0
35.0, 36.0
-

iPad®

-

7.1

-
-

iPad® mini

-

7.1

-
-

Please use one of the approved browsers to ensure the security of your online banking activities and to experience the functionality of all e-Bankoh features.

 

Additional Requirements:

  • Internet access and e-mail service.
  • All approved browsers should:
    • Support 128-bit encryption.
    • Accept Cookies
    • Have JavaScript enabled.
    • Set pop-up blockers to off or low
  • It is also recommended that you have a printer connected to your PC.

e-Bankoh Mobile System Requirements:

An internet-enabled device such as a cell phone, smart phone or PDA is required to access e-Bankoh Mobile at m.boh.com. The following platforms / OS versions are supported (updated 06/2015):

Platforms / OS Version
Devices Tested*
iOS 6.0
iPhone 4s, iPad 3
iOS 6.1

iPhone 4, 4s, iPad 2, iPad 3, iPad 4, iPad Mini, iPad Retina

iOS 7.0
iPhone 4, 5c, 5s, iPad 2, iPad 3, iPad 4, iPad Mini
iOS 7.1
iPad Mini, iPhone 4s, iPhone 5
iOS 8.0
iPhone 4s, 5, 5s, 5c, 6, 6 Plus, iPad 2, iPad 3, iPad 4, iPad Air, iPad Mini Retina
Android 4.0
Samsung Galaxy Tab 10.1, HTC One X, Samsung Galaxy S2, Samsung Galaxy Tab 2, Kindle Fire HD 8.9 (2nd Gen), Kindle Fire (2nd Gen), Kindle Fire HD 7, Kindle Fire HD 8.9

Android 4.1

Moto Xoom, Moto RAZR HD, Samsung S3, Samsung Galaxy Tab 3, Samsung Galaxy Nexus 10, HTC One X, HTC One M7, LG-P716, Xperia Z Tablet

Android 4.2

Samsung Galaxy Nexus 7 Tablet (1st Gen), Samsung Galaxy S4, Samsung Galaxy S4 mini, Kindle Fire HDX 8.9, Kindle Fire HDX 7

Android 4.3

 LG Nexus 4, Nexus 7 Tablet (2nd Gen)

Android 4.4

Nexus 5, Samsung Galaxy S5

  *Mobile Deposit service requries the device have a built-in-camera.
For Android tablets, camera must have a rear-facing camera with auto focus.

Bank Text Messages System Requirements:

  • Cell phone device that has text message capabilities
  • A carrier that supports text messaging and the text messaging protocol standards required by our wireless application service provider.

Quicken Software Requirements:

  • Quicken software updates occur annually. Please be sure you have updated your version of Quicken within the last two years.